Subject: Another 1.0-BETA data point...
To: macbsd-general mailing list <>
From: None <>
List: macbsd-general
Date: 10/28/1994 14:17:41
Just FYI...

I have an SE/30, System 7.1, 8M memory, and assorted hard drives (16M
swap partition).

The last version I installed was one of the 0.9 betas several months
back.  I re-mkfsed my root&usr partition and installed from the latest
binaries earlier this week.  (Kudos to whoever added the gzip code to
the installer.  It helps a lot.)

Some points of interest:

- One of my ADB devices (an EMAC Silhouette trackball) seems to wedge
the boot process consistently at the same point every time.  (In the
middle of the configuration message for the 'ite0' mini-console - the
first two letters of the device name ('it') get printed, and then it
hangs.)  I solved this by using an Apple mouse instead.

- Having Mode32 installed and 32-bit mode turned on seems to cause an
infinite loop of "Panic:  kernel jump to zero" messages when booting.
Booting in 24-bit mode works fine, though.  (This could be a conflict
with something else, but after turning off Mode32 fixed the problem I
didn't pursue it any further.)

- The latest version of dt (the one put on cray-ymp Oct. 26 by David
Holcomb) dumps core when I have my RasterOps 264 video card installed.
I don't have a monitor to attach to it right now anyway, so I removed
the card and dt works great.  BTW, this card _did_ work with the
multi-screen code in the pre-dt virtual consoles, and it appears to be
recognized and configured correctly during boot.  I think dt is doing
something bad on multi-screen setups.  :-(

- In trying to debug the dt problem, I found that gdb seems to have a
lot of problems debugging a running process, even when the program
being debugged has been compiled with optimization off.  Most variables
show up with zero values, I get random messages saying "address not
accessible - no such process" (or something like that), and it
occasionally drops into the kernel debugger on the console with some
odd message about interrupts (I was able to continue and keep running,

On second thought, it could be some bad interaction with the display
memory mapping - I haven't tried debugging any programs besides dt

Are there known problems with the debugger, or am I doing something

- You may already know this, but when the ADB lockup bug happens,
everything else still works normally, including output to the (non-dt)
console.  It's just ADB input that gets hosed.  (I was logged in
through the serial port, and `cat >/dev/console` worked just as one
would expect.)

Overall, things look great.  Having the familiar arrow cursor pop up
over the console screen is pretty strange.  I like it.  :-)  

To the core developers (do you still call yourselves the Alice team?)
-- keep up the good work!  I'm looking forward to seeing X run on my
SE/30.  (if I ever get a spare hard disk big enough to hold it! :-)

- monroe
Monroe Williams