Subject: IIvx with 1.0-BETA
To: None <>
From: Ben Cottrell <benco@CSUA.Berkeley.EDU>
List: macbsd-general
Date: 10/23/1994 19:53:20
I have a IIvx, 8 MB RAM, no other hardware except a rather odd SCSI
configuration with 1 gb drive with MacBSD on it at id 6. Trying to boot
into single user gives the following message:
[ preserving 73439 bytes of netbsd symbol table ]
and proceeds to draw 12 gray bars, after which point it hangs.

My saga is as follows. I formatted my 1 gb drive with HDT Primer into a
root partition, a swap partition, and a MacOS partition to store the tarfiles
and related junk in. I installed all of the 1.0-BETA tarfiles, and at a point
during the installation noticed that when doing an ls on /, right after it
listed the kernel, it would say
fstat : No such file or directory.
Question: Is this harmful? I assumed so, because I assumed that there was an
entry called fstat in the directory for . and no inode.

So, I re-mkfsed and went through the exact same process, except making sure
to keep my usage of the mini-shell to a minimum. When the exact same error
occurred, I decided to try booting anyway, and let fsck deal with whatever it

I connected my Quadra 605 to the IIvx by way of a System/Peripheral-8 cable
to act as a serial console, set the correct options in the Booter, flipped
over to black-and-white mode just in case, and booted. The 12 gray bars
appeared, and then it hung. I repeated the experiment, with the same results.

Then, I mkfs'ed a third time and this time only installed base10, netbsd10,
and built the devices. I didn't enter the mini-shell this time, so I don't
know whether the fstat error was still there. I tried booting again, and
got exactly the same result.

I thought that the 1.0 kernel worked on the IIvx except without ADB? All
three times I tried booting, I had extensions off, so I know I'm not setting
some weird interrupt or anything. Could it have to do with the fact that I'm
running a beta version of System 7.5?

Also, I have two miscellaneous questions:
        * For the serial console option in the booting... dialog, what baud
          rate does it set the serial port to? In other words, to what rate
          should I set the terminal on the other end?
        * Should I subscribe to macbsd-programmer also? I'm not currently
          involved with kernel hacking or anything, but I would like X11,
          and I've heard that there was an announcement about that in
          macbsd-programmer a while ago.

Thanks to all the people that have gotten MacBSD up even to this extent!!