Subject: Re: dt, non-single boot, control chars & #
To: Juliana Fleming <>
From: Lawrence Kesteloot <>
List: macbsd-general
Date: 08/26/1994 00:42:49
> setting tty flags
> ser0: ioctl(,-2147191716,,)
> ser1: ioctl(,-2147191716,,)

Comment out the call to ttyflags in your /etc/rc file.  This has been
fixed in the latest code, which hasn't been released yet.

> # dt
> (then, interestingly enough, the vt comes up on my external radius...)
> bash: no such file or directory

Hmmm.  I've definitely fixed this, but I guess that I haven't released
a version since then.  You can either "ln -s /bin/sh /usr/local/bin/bash",
or you can edit the main.c file of dt and change the string that's used
to call the shell.  Oh, you can also get bash from gnu, compile it, and
stick it in /usr/local/bin.

> also, from looking at the mailing-list archive i see that i was/am not the
> only one with the repeating # problem. is this solved in dt?

The problem is not solved, and we don't have a clue how to solve it.  It
does not happen when dt is running though, so just type really slowly
until you get to the point where you can run dt, and then you should be

(What happens, as far as we can tell, is that you press <ENTER> at the
bottom of the screen, and release it just as the screen is scrolling
up.  While the screen is scrolling, keyboard interrupts are disabled
(and I can definitely place the blame of that on Apple for putting
keyboard at the bottom of the interrupt ladder) and the key-up is
lost.  The kernel thinks you're still holding it down, so it keeps on
pressing <ENTER> for you.  In addition, the lost interrupt has caused
the keyboard to get all upset and no more interrupts happen, ever.  So
press <ENTER> slowly so that the key-up doesn't happen during