Subject: my first results trying MacBSD on Duo 270c
To: None <>
From: David Avraamides <>
List: macbsd-general
Date: 07/20/1994 09:51:34
Hi All,

I tried to get MacBSD installed on my Duo 270c last night. Here's 
some feedback from the process.

(Aside: the 270 DOES have a 68030 in it AND and FPU, contrary
        to some other statements I've seen. The 270c is 8-bit
        active matrix color, 33MHz and mine is a 12MB RAM,
        240MB HD configuration)

  - it doesn't boot (I was warned). I know someone mentioned that
    the booter uses the Shutdown manager which on PBs and Duos with
    Power managers causes the ADB and SCSI to be turned off so I
    wasn't really expecting much anyway. I just wanted to see if
    the file system got installed ok. No complaints from the booter
    it just started the process, printing out some info, then gave
    me the warning "... not tested on this machine, it probably
    won't boot..." then my system hung. The mouse cursor would
    move but I couldn't do anything. The screen was frozen - no
    gray bars even though I checked the box. All I could do was
    hit the reset button in the back (which powered it down) then
    turn it back on. 

    I was using tar files from BETA-1 and the 1.1 booter.

  - I couldn't get some of the tar files installed. For files that were
    too big to fit on a 1.44MB floppy (such as usr.bin.tgz), I tried
    to split them up on my sun and break them into multiple tar files
    but when I selected them using the MacBSD Installer I got the
    following error:
      Choose file #0 to unpack (0 is first)
      Unknown file type--pretending it's a regular file.  Will not attempt to unpack
      -r-xr-xr-x 242 200   81920 Wed May 04 02:38 1994 usr/bin/Mail
      Oh, dear, I have reached a file type I don't know how to handle.
      chmod : No such file or directory
      Failure to convert tar header, 1....
      Choose file #0 to unpack (0 is first)
      tar header read operation cancelled

   What's the buzz? To split them up I unzipped and extracted them.
   Then I broke them up into multiple tar files using an include file
   (tar cvf usr.bin1.tar -I lst1) where lst1 contains some of the
   files in usr/bin. Then I gzipped them, copied to my Mac and gunzipped
   them. I thought a tar file was a tar file was a tar file... ??
   I even copied a file back to the sun, unzipped and extracted it
   fine - so its not a corrupt file. Do I need to use a special version
   of tar?? 

 - I was wondering if there will be a way to remap keys on the Duos
   when the keyboard support gets done. The Control key is hard to
   get to on the Duo and swapping it with the Caps Lock key would be
   ideal, if possible, as I never use it and its right where you would
   expect to find the Control key. I've heard this is a pain since
   the Caps Lock key only sends a key down when you first press it,
   then a key up when you turn it off. But maybe thats at the ROM
   level which wouldn't matter here. Anyway, xmodmap should be able
   to fix it. (It won't even boot and I'm already looking for X support!)

Well, if you would like me to try anything out and give you some
feedback, let me know. I don't have a SLIP connection I can use
and I don't have a serial terminal or anything like that so the
only tests I could run would be standalone on the Duo (unless
I can connect my Newton to it and use it as a terminal!! :-)