Subject: Re: configuring a new swap
To: Allen Briggs <>
From: Brad Grantham Featuring 24 Hour Alarm <>
List: macbsd-general
Date: 04/20/1994 22:21:33
> > I'm having some trouble adding a swap partition.  I'm trying to add it on
> > an external drive at sd1b.  Whenever I run swapon -a it says that it is not
> > configured.  What does it take to configure it?
> Does swapinfo -k give you multiple devices or just one?  You might need to
> reconfigure the kernel with something like:
> 	root on sd0 swap on sd0 and sd1

This shouldn't be necessary (but that doesn't means it isn't); please
post a copy of your /etc/fstab and output from "disklabel /dev/sd1c".
There should be an entry for "swap" under fstype for partition "b".

Have you tried "swapon /dev/sd1b" at the root prompt?

Putting /dev/sd1b in my /etc/fstab was all I needed to begin using my
other partition.  It sounds to me like you may have a problem with your
partition, but it would help to see more detail.

Brad Grantham, ---------- Happily slaved to NetBSD/Mac68k!
 I think "make love, not war" is probably too extreme.  I think the sentiment
	might be better phrased, "make grudging tolerance, not war."
!!! UNIX forever, NT never, UNIX forever, NT never, UNIX forever, NT never !!!