Subject: compiling gives me fs crash
To: None <>
From: Ken Nakata CS major/CIS dept. <>
List: macbsd-general
Date: 04/05/1994 02:06:24

I got MacBSD up and running on my SE/30 with 5M ram.  I've got
ksrc.tar.gz and so on from cray-ymp:~NetBSD_Mac/compile_kern
and all the src tar files from sun-lamp or
then tried to rebuild kernel.  The attempt gave me a kernel panic
"bad dir".  After rebooting, fsck reported a couple of
minor (I thought) fs errors, so I repared them and continued kernel
make.  Then make or cc dumped core and the machine hang up.
This time the root directory got corrupt so I had to reinstall from

Today, I tried to recompile src/*bin dirs for ps gives me infamous
"proc size mismatch" error, and got a panic again.  I'm not familiar
with kernel debugger at all, so I couldn't track down the problem.

The kernel is cray-ymp:~NetBSD_Mac/new_kernels/netbsd-012394, and the
tar files are dated Jan. 5, 94, also from cray-ymp.  Originally, I got
only usr.libexec.tar from and suspected it.  But
I still get panics after replacing it with the one from cray-ymp.

Machine is Mac SE/30 (5M ram).  The disk is partitioned as following:
name	offset	size	cyl	type
sd0a	176	129360	112	ufs
sd0b	129536	40425	35	swap
sd0g	169961	1700160	1472	ufs
---	1870121	230824	199.85	HFS
total	---	2100945	1818.85	--- (15 heads/cyl, 77 sec/trk)

(btw, I didn't notice until now that my all partitions are *not*
aligned on the cylinder boundary... can it cause any problems?  MKFS
didn't complain at all... Anyway, I don't like this, so I'll try to
align them and see what occurs).

I appreciate any pointers.

Ken Nakata