Subject: Re: Memory, ser0, sl0, fast clock, etc.
To: Allen Briggs <>
From: John D. Smerdon <>
List: macbsd-general
Date: 04/02/1994 21:52:13
>Yes.  Just once.  When I had compiled NFS stuff into my kernel.  Does
>it happen if you don't config in netstart?  Which kernel are you running?

The kernel is macbsd.940123 from the last update.tar and the booter is 1.0.

If I have the following lines in netstart or rc.local, it always crashes
when entering ps -ax.

# slattach -h -s 57600 /dev/ser0
# ifconfig sl0 inet up
# route add

If I don't put them in netstart or rc.local, login as root, and then enter
the same lines it works OK.

I have found that the console usually freezes later (no longer takes
characters or cmd-2, etc.) although the SLIP line works OK.  I think the
freeze happens after I do a ftp transfer to the MacBSD system.  A message
is displayed on the console about receiving duplicate messages.  Don't know
if it is related but I think it is.

>Yes.  You need to reconfigure the kernel and recompile.  I haven't tried
>two slip interfaces before ;-)

I am trying to config the new kernel.  The INDEX mentions a README document
for compiling the kernel.  Does this exist?

>> I originally tried to setup pppd, but the serial driver does not like the
>> TSETIOD (?) ioctl.
>oops.  That's been added to the to-do.

If I get the kernel compiled, I was going to try to fix this.  Don't know
what actually needs to be done though. :-)

>Constantly fast--as in it's still off by the same amount an hour later?
>I have a problem with my SE/30 in that the clock is almost never read
>correctly...  I get dates that range across a century.

Yeah, constantly.  I saw a large constant that converted the date from 1904
to 1970.  I was going to check that.

John D. Smerdon; Plymouth, Michigan; Contents are my opinion.
Internet:; UUCP: umcc!smerdon!jds