Subject: The latest MacBSD Installation Problems
To: None <>
From: Bharat S. Jhaveri <bjhaveri@Arco.COM>
List: macbsd-general
Date: 03/29/1994 08:44:45
>  With your help, I did figure out the problem. I was booting the new
>kernels with the old booter that was working with the netbsd.CI kernel.
>Today I completely changed the system by getting the latest tar_files from
>kitten from dist.tgz modified last on feb 28th. It boots with the latest
>1.0 booter. Although rebooting ia hard. Now, I know that I have to ;
>1) Completely shut and start the mac;
>2) Make sure thar memory in booter is 16meg from bank A in CI(I have 4 Meg
>in Bank B. Booter initializes 20 Meg). The booter has hard time. It wants
>to auto-size RAM. But I found after hard work that only, bank A Meg should
>be used. I hope this will work all the time.
>   My real question. Where is /dev/ser0 for the modem and /dev/ser1 for the
>printer in the new system. I saw /dev/tty, /dev/tty1, and/dev/tty0. I tried
>them but did not work. Please let mr know.

  Allen: After few more hours last night and today, I found that I can boot
with the lates (Feb 28) MacBSD system all the time. But, I have gotten into
problem with tip. As I wrote yesterday, I was once again setting up a slip
connection. I used 'tip com0' initially. where 'com0:du=/dev/tty0' in
/etc/remote. This had worked before with the alpha version of the MacBSD.
First couple of time tip connected the link to /dev/tty0, but locked the
terminal. Now, it seems hung. I boot OK. but when I type 'tip com0' I get

    kernel trap
    calling kdb_trap(15,&frame)
    stopped at 0x4de04

and I have to rebbot. Did I screwup tip? I know this had worked before.
Should I reinstall all or some of the tar_files? Or should I go back to the
alpha version?

    Oh yes. A few things. When I installed the New Version of the system,
initial boot(the first) got me into a loop. To create /etc/fstab file. Ir
tried to create one based on my input of '0' for the Unit no. But it never
could. Said that Disk is read only. Once I mounted the disk by creating my
own fstab file by editing file, it said file permission denied on
/etc/rc file. So, I had to chmod a+x on /etc/{rc,rc./local,rc.install}.
Since, I did not go through the intended startup procedure, did that cause
problems that lead upto tip screwup?
Anyway now I know that I can always boot my IIci as long as I put Bank A
memory in the RAM in the booter.

   Also, from my previous tip setup, I had a hard time even then. I vaguely
remember a problem with file ownership for some lock file in /var, For tip
and cu to work properly. But I forgot. Maybe that is why tip can not start?

   BTW I think /dev/tty0 is connected to modem OK. When I do 'echo ATDT
>/dev/tty0' the modem lights flash.

   I think the new version of the MacBSD system should work fine. I would
hate to reinstall the alpha version again.
   Thanks for your invaluable help.

Bharat S. Jhaveri