Subject: Re: recompiling the IIci kernel
To: Allen Briggs <>
From: Bharat S. Jhaveri <bjhaveri@Arco.COM>
List: macbsd-general
Date: 03/28/1994 22:41:27
>>   I guess that I do have a problem. I got the recent kernel from kitten. I
>> was not able to boot. It did give a message that it was trying to boot, but
>> it hangs up. I got quite a few kernals and tried them they all hung up.
>Where do they get "hung up"?  How far do they get (how many gray bars, if it
>doesn't even get to clearing the screen)?
>>   I know that this kernel netbsd.CI has alwas booted. But quite a few times
>> I have to reboot because fsck gives a lot of errors.
>???  After clean shutdowns?  How are you shutting down the system?
  With your help, I did figure out the problem. I was booting the new
kernels with the old booter that was working with the netbsd.CI kernel.
Today I completely changed the system by getting the latest tar_files from
kitten from dist.tgz modified last on feb 28th. It boots with the latest
1.0 booter. Although rebooting ia hard. Now, I know that I have to ;

1) Completely shut and start the mac;
2) Make sure thar memory in booter is 16meg from bank A in CI(I have 4 Meg
in Bank B. Booter initializes 20 Meg). The booter has hard time. It wants
to auto-size RAM. But I found after hard work that only, bank A Meg should
be used. I hope this will work all the time.

   So, I will be able to use the new kernels after all. Recompile it for
57600 bps, like you mentioned.

   My real question. Where is /dev/ser0 for the modem and /dev/ser1 for the
printer in the new system. I saw /dev/tty, /dev/tty1, and/dev/tty0. I tried
them but did not work. Please let mr know

   I hope this new system works well, or I might go back to the old
one(tar_files from cray-ymp from Jan)

   Thanks for all the help you have given. I have found this exremely hard,
but then I am impatient and I want to finish what I start, (usually).


Bharat S. Jhaveri

ARCO Exploration
 & Production Technology

(214) 754-6407