Subject: macBSD wont boot on my SE/30 - why?
To: None <>
From: Ulf Eriksson <>
List: macbsd-general
Date: 02/13/1994 21:37:10
I need some help with this please.

There is a lot to read down here, but in short I've got a problem
with my UFS partitions OR kernel that make something panic and dump.

I've tried to install macBSD onto my minimal machine.

1) This is what I have:
	- Mac SE/30
	- 40Mb HD
	- 4 Mb RAM.

	I know that this is not much but it should do for testing.

2) This is what I've tried:

	- Install netBSD 0.9 with files 1.tar to 12.tar excluding nr 13.
	  These files are dated aug 1993.

	- Install netBSD-current with the files above and the files named
	  bin.tar, etc.tar, dev.tar etc dated dec 1993.

	- I've used all kernels I could find including the one in update.

	- I've tried to use installer 0.2 and 0.3 and the all the booters.

3) Partitions:
	- I have made all kind of partitions and tried:
		i) 	2 Mb Mac volume
		   	6 Mb swap
		   	32 Mb root&usr

		ii)	2 Mb Mac volume
			6 Mb swap
			6 Mb root
			26 Mb usr

4) Formating software:
	- I have used LaCie Silverlining and DiskManager Mac.

	- I have then used mkfs on all of these partitions.

I have tried all combinations of all above with no luck.

The funny thing is that I have before installed macBSD from disks and with
much smaller partitions to be able to load the tar-files on the mac volume.
And it worked though the screen updating was not good.

5) This is what happens:
	- The boot goes fine, I get all the magic numbers and the grey bars.

	- I get the copyright notice and the following rows appears

	  NetBSD 0.9 (ALBASIC) # 135: Thu Aug 26 20:12:26 GMT 1993
	  root@: /usr/src/sys/arch/mac/compile/ALBASIC

	- It all looks fine with a big nice typeface (12 pt), then it
          asks me if I want to fsck rsd0a and I answer yes.

	  Then, after a lot of ret keys from me it says:

	  DISK SECTORS COULD NOT BE READ 16, 17, 18,.....,31
	  ioctl(): default cmd = 0x41146465
	  ioctl(GCINFO): Inappropriate ioctl for device /dev/rsd0a:
	  can't read disk label

	  /dev/sd0a on /: Specified device does not match mounted device.
	  /dev/sd0g on /usr: Device not configured.

	  Filesystem	kbytes	used	avail	capacity	mounted on
	  root_device	31231	13718	14389	49		/

	  panic: kernel jump to zero

Help, what have gone wrong??

None of the formating programs report any errors about my HD.

I would appriciate all help I can get. I'm really sick of the Mac OS,
I want UNIX...

	  Why do you need a mac partition, whats the problem with booting from
	  a UFS partition. Is it that the M68K vectortable is in ROM and wants
	  an HFS partition?? As a pseudo-thing couldn't one make an INIT that
	  asks at startup what partition one wants to boot from and get rid
	  of that booter appl. ??

	  Any news about integrating the HFS into macBSD??


Thanks in advance..

Ulf Eriksson
Computer science student @ Lulea University of Technology


E-Mail:  OR