Subject: None
To: None <>
From: Ted Giering <>
List: macbsd-general
Date: 01/22/1994 13:07:36
	I was having problems bringing up Alpha2 on an SE/30 similar
to many others on this list: the boot sequence would freeze
immediately after the disks were mounted, and none of the binaries
from Alpha2 would run under the Alpha 35 system.  I had decompressed
the Alpha2 system using MacCompress, so I read the message from Greg
Becker about the dangers of decompressing with the CR <--> LF menu
option set.  I examined the decompressed files, however, and found
that they all still had both CR and LF byte values in them, which
would seem to indicate that neither had been converted to the other.
	However, there is another way to get this wrong.  MacCompress
also has a menu "Format" with the options "Mac Compress" and 
"UNIX Compress", and the default is "Mac Compress".  I don't know what
"Mac Compress" means, but, unbelievably enough, MacCompress will
unpack a UNIX compressed file with this option set, and the resulting
(tar) file will be unpacked correctly by tar and by the MacBSD Install
utility.  I say correctly, but only in that the file names and sizes
are correct.  The contents appear to be some variety of garbage, not
at all similar to the result obtained if the "UNIX compress" option is
used, and definitely not executable (at least not on a 68030).  In the
immortal words of the MPW Compare utility, "nothing seems to match".
	I still need some help, however.  Having downloaded a new set
of files and decompressed them correctly, Alpha2 boots in single user
mode.  It will not boot in multiuser mode from the MacOS booter; it
gets to the point of the logon prompt and reboots.  If I boot in
single user mode and then enter a ^D, the boot sequence continues,
complains about a few missing files in /var, and gives me a logon
prompt.  However, I can't log on.  I tried using the supplied passwd
file, and it will not allow me to log in as any of the accounts.  I
tried replacing it with the supplied master.passwd file, and adding an
account for myself with no password and with an encrypted password
from a Sun runing SunOS 4.3, a BSD derived system.  Nothing seems to
matter; it refuses to let me log on.
	Does anyone have any idea what I am doing wrong?

 Ted Giering | 207 Love Building
 2632 Nantucket Lane             | Florida State University  32306-4019
 Tallahassee, FL  32308-2246     | (904)  644-3441, 668-4156/4157 (home)