Subject: My attempts at Alpha2 on an SE/30...
To: None <>
From: None <NABER_MICHAEL@Tandem.COM>
List: macbsd-general
Date: 01/10/1994 21:49:00
I, too, have been stymied at getting Alpha2 running on an SE/30.
Here is what I have come up with, after many tries.

    Mac SE/30, 8MB RAM, Quantam 240S partitioned with APS 2.73,
      external color monitor (set to 1-bit mode) with a
      "Lapis ColorServer LC & PDS/30 -21 board".

I have modified the owner and permissions for sbin/init and dev/console,
as suggested by someone else.

With the Alpha2 versions of everything installed, the system hangs
immediately after the message:
  A: Root 'UNIX Root&Usr slice 0' at xxxxxx size yyyyyy
I can still switch virtual consoles, although it's a bit useless as
none of them have a prompt.

I read the mail about turning on 32-bit mode prior to booting Alpha2,
and decided to try it.  No version (either Alpha 35 or the latest
Alpha2) will boot with the 32-bit enabler installed and 32-bit mode
enabled - no grey bars, just the part up to shooting your dog.

I have enough space for now on the UNIX partition that I have both
versions installed, the working Alpha 35 version and the latest

I noticed that the two versions of etc/rc are drastically different,
with the earlier version performing an echo of "Running etc/rc...".
Since the newer one didn't have this, I placed it at the beginning.
No message upon a boot!!

Next, I tried putting the old version of /etc/rc into the new /etc
(I switch between versions by renaming the directories with the
installer).  In this case etc/rc is invoked, but I still end up with
an unusable system.  Here is what I see:

  Running /etc/rc...
  Do you want to fsck /dev/rsd0a? (y or n)? [y given, and fsck worked]
  Do you want to fsch /dev/rsd0g? (y or n)? [n given]
  Filesystem   1K blocks ...

        386BSD (Amnesiac) (con1)

  login: Jan 10 20:41:22 getty: dev/vga: No such file or directory

There is no dev/vga (and why would a Mac want to talk to a VGA device?).

I hope this helps a little in getting to an answer.

Michael (