Subject: Alpha2 binaries on an SE/30
To: None <>
From: Ted Giering <>
List: macbsd-general
Date: 01/09/1994 09:12:42
	The only way that I can run MacBSD on my SE/30 (8 Mbytes
memory, Quantum 40S at SCSI 5, Quantum 105S at SCSI 0) is to use the
"old" release (in tar files 1.tar, 2.tar, 3.tar, 4.tar, and t.tar) and
to use a relatively new kernel (I am using netbsd.II at the moment).
All attempts to use the Alpha2 files have failed.  I tried the files
at and at
When I install this release, the boot always freezes immediatly after
mounting the disk partitions.
	There was some traffic on this list about incorrect ownership
and permissions on certain key files causing this to happen.  I booted
MacBSD using the "old" release and then loaded some of the new files
in alternate directories.  I did find that /sbin/init had different
ownership and permissions in the two releases, but changing this did
not fix the problem.
	I then had a closer look at the two sets of binaries, and
found that they had very different sizes.  For example, the "old"
version of /bin/ls:

-r-xr-xr-x    1 root     bin         53248 Aug  2 22:40 ls*

vs. the version on bin.tar:

-r-xr-xr-x    1 bin      bin        114688 Dec 12 15:57 ls*

I tried executing the Alpha2 binaries, and all of them crash.  For
example, attempting to run the Alpha2 ls gives:

bus error-core dumped

	This means that either the Alpha2 binaries are incompatible
with a system booted using the "old" files (this seems unlikely; I am
after all using a new kernel), or they are incompatible with my SE/30.
In the latter case, this may be causing the problem with booting
Alpha2 on the SE/30.  Has anyone mangaged to get Alpha2 running on an

		Ted Giering