Subject: SE/30 Problems with Alpha2
To: None <>
From: Ted Giering <>
List: macbsd-general
Date: 01/01/1994 10:43:21
	I have been having problems booting MacBSD on my SE/30, and
I wanted to see if anyone knew what was going on.
	My first attempt was to install the tar files from, downloaded on Christmas day.
I formatted a 40 Mbyte disk with an 8 Mbyte swap partition (for 8
Mbytes physical memory) and a 32 Mbyte root&usr partition using HD
Setup, and installed all of the tar files except for usr/include and
usr/libexec.  I then copied the netbsd-current kernel to /netbsd and
tried to boot.
	The boot sequence proceeded up to the point where it output

B: Swap 'Swap' at 96 size 16384
A: Root 'A/UX Root' at 16480 size 65549

on the screen, then froze.  I tried to capture the complete boot
sequence using the serial echo feature, but found that this did not
work even up to this point:

Copyright (c) 1982,1986,1989,1991 The Regents of the University of
All rights reserved.

NetBSD 0.9a () #9: Thu Dec 23 03:46:24 EST 1993
Apple Macintosh SE/30 (68030)
real mem = 8384512
avail mem = 5693440
using 127 buffers containing 520192 bytes of memory
Kernel booting; please have lunch, maybe a pizza.
mainbus0 (root)
adb0 at mainbus0
nubus0 at mainbus0
grf0 at nubus0: 512 x 342 1 color MacVideo (Macintosh SE/30 Internal
Video) disp
ser0 at mainbus0
(serial boot echo is on)

After printing the "}" character, there was no further output.
	Since the FAQ said that MacBSD had been successfully booted on
the SE/30, I thought that this might be a problem with the new Alpha2
release, so I got the first 5 tar files ([1-5].tar) of the original (I
think) release from  I cleaned off the
disk and installed them.  This produced different results, but it
still did not boot.  The serial echo feature worked with this kernel,
so I was able to capture the whole sequence:

NetBSD 0.9 (ALBASIC) #135: Thu Aug 26 20:12:26 GMT 1993
Apple Macintosh Pentium (68030)
real mem = 8384512
avail mem = 6725632
card is Macintosh SE/30 Internal Video, Apple Computer
type is 3
No ADB drivers to match to devices; using default.
Initializing drivers:
Video Device  -- Width: 512 Height: 342 Depth: 1 Bit
ncr5380(0): Probing for scsi devices.
ncr53800 targ 0 lun 0: type 0(direct) fixed <QUANTUM LP105S
9101094052.3 > SCSI2
sd0 at ncr53800 targ 0 lun 0: 99MB 1219 cyl, 4 head, 42 sec, 512
ncr53800 targ 5 lun 0: type 0(direct) fixed <QUANTUM P40S
940-40-94xx7.9 > SCSI1
sd1 at ncr53800 targ 5 lun 0: 39MB 834 cyl, 3 head, 32 sec, 512
ncr5380(0): Found 2 devices.
ser: entering serinit()

                        ser: exiting serinit()
Two MacII serial devices--one in use for debugging.
Nubus slot 14 not claimed: "Macintosh SE/30 Internal Video, Apple
Swapping sd1 and sd0

Running /etc/rc...
crw-rw-rw-    1 root       0,   0 Aug 24 23:19 /dev/null
Do you want to fsck /dev/rsd0a? (y or n) n
Do you want to fsck /dev/rsd0g? (y or n) n
/dev/sd0a on /: Specified device does not match mounted device
/dev/sd0g on /usr: Device not configured
Filesystem   kbytes    used   avail capacity  Mounted on
root_device   31077   13718   14251    49%    /

MacBSD Virtual Console number 1 -- Press -1 to -4 to switch.
panic: kernel jump to zero
syncing disks... done
we read ret=74, tmp=74 (tmp+1) &0xff= 75
WARNING: cannot set battery-backed clock.

dumping to dev 401, offset 8
dump sddump() -- not implemented

At this point, the Macintosh rebooted to System 7.
	At this point, I tried using the new kernel (netbsd-current)
with the old release.  This booted successfully.  To try to track down
the problem with the new release a little more, I tried installing tar
files from the new release on top of the old one.  With a new /etc
there were no problems.  With a new /bin, the boot froze at a slightly
different point than before.  As before, it printed

B: Swap 'Swap' at 96 size 16384
A: Root 'A/UX Root' at 16480 size 65549

to the screen, then said something about entering the virtual
terminal.  Indeed, it seemed that the virtual terminals had been set
up; it was possible to switch between them.  However, no shell was
started in any of them.  Installing the new /bin made the boot freeze
in exactly the same way as when I tried to boot with the complete
Alpha2 installation.
	That is as far as I have gotten, and I don't think that I will
be able to work on this any more for a while.  Am I doing something
wrong, or could this be a problem with the new release?

Ted Giering