Subject: Status of NetBSD/Mac -current
To: macbsd-development <macbsd-development@NetBSD.ORG>
From: Paul R. Goyette <>
List: macbsd-development
Date: 07/15/1995 08:39:58
Well, the random core dumps that Allen once described as "the bad things" 
still happen occassionally with -current (as of 7/14).  They always seem to 
say "Bus error".  Maybe it has something to do with a rather fast disk, 
or varying disk speeds?  I've got a standard 3600rpm 1GB drive at sd0, 
and a 5400rpm 3.5GB at sd1.  (sd1 has /usr, /home, and a second swap 
file, while sd0 has /, /var, and primary swap).  

Also, I still get unexplainable errors during shutdown or reboot, 
right after the "syncing disks...done" message.  I get an (apparently) 
infinite loop complaining about dirty blocks with seemingly random 
refcounts.  This seems to happen only if I've done a make install in /src - 
otherwise the shutdown goes clean.  I recall that someone recently posted 
a note about problems encountered in similar situations, where an install 
left some executable or library in a state where its only reference was 
the currently executing copy;  the install deleted the last directory 
reference to the file.  That post indicated that the lost file wasn't 
even cleaned up by fsck.  Maybe this is a related problem?

Reboot still doesn't reboot, hanging right after the "MacBSD doesn't trust 
itself to write to pram" message.  Shutdown -h still successfully halts 
the machine, though.

All of this is on a Mac IIci with 24MB RAM, internal video (and an 
installed but unused Futura SX vieo card), and the above mentioned disk 

| Paul Goyette            | Key available via finger or key server |
|   | Fingerprint: 0E 40 D2 FC 2A 13 74 A0   |
|                         |              E4 69 D5 BE 65 E4 56 C6   |