Subject: Re: -current kernel STILL goes splat!
To: Valtteri Vuorikoski <>
From: Bill Studenmund <wrstuden@loki.Stanford.EDU>
List: macbsd-development
Date: 07/10/1995 09:56:56
> Bill Studenmund has randomly hit several keys, resulting in
> > Pram time does not appear to have been read correctly.
> > Pram: 0x83da5123, macos_boottime: 0x2fff0551
> > Kernel FPU trap.
> > trap type 2, code = 0, v = 0
> > kernel: Illegal instruction trap
>  I saw the same on my IIsi with home-compiled kernels, but the problem
> went away after I did a make clean and remade all.

Thanks for the suggestion. I tried it, but it didn't help. I tried re-
configing, making clean & depend & make to no avail.

I even removed /usr/src/sys, pulled it off of this week's tarball, and:
cd /usr/src/sys/arch/mac68k/config
config GENERIC (The config is a week old; the sources haven't changed since
                      late April)
cd ../compile/GENERIC
make depend && make
mv netbsd /
shutdown -r now

I then come in w/ booter 1.6, either w/ or w/o extensions.

The kernel boots fine, gets to the line about the time being off, and
     dumps me into db w/ an FPU exception.

At first I thought it was the time calculation was off. Numerous printf(
"I'm here, dear\n"); statements show the problem is when the kernel is
forking off init.

It finds init, only to choke in the execve. Specifically at the copyinstr
called the first time through the loop that reads in the arguments.

----- begin including kern_exec.c -----
        if (pack.ep_flags & EXEC_SKIPARG)

        while (1) {
                len = argp + ARG_MAX - dp;
                if (error = copyin(cpp, &sp, sizeof(sp)))
                        goto bad;
                if (!sp)
#     Makes it to this line, but chokes w/ a page fault
                if (error = copyinstr(sp, dp, len, &len)) {
                        if (error == ENAMETOOLONG)
                                error = E2BIG;
                        goto bad;
                dp += len;
-----  end including -----

I can believe that I have something set wrong, but the kernel source
is this week's tarball, and my mac-side config works for my Happy_IIsi
kernel. I have a IIsi running 7.1 and booter 1.6.

Any help will be appreciated!

Take care,