Subject: Re: BETA-1
To: None <>
From: CS major) < (Nakata Ken>
List: macbsd-development
Date: 05/05/1994 01:46:15
>Date: Thu, 5 May 94 00:19:16 -0400
>From: (Nakata Ken (CS major))
>Precedence: bulk
>>> introduced with BETA-1 (I have never got a kernel panic with BETA-0
>>> kernel), and self configuration procedure doesn't run successfully
>>Could you tell me when the panic(s) happened?  I think it's the same
>>kernel as BETA-0...  It is the same kernel that I've been running for
>>several days, now...

I got some more info. from kernel debugger.  Actually, it was some
sort of filesystem inconsistency... fscking stopped panics which were
"panic: ialloc: dup alloc".  Sorry for my bogusity.  But sometimes
fsck can't clear unref file that causes panics.  Inconsistency between
inodes on disk and those in core?

>>> I tried to see what's wrong with /etc/rc, but I couldn't do that due

It looks like /etc/rc assumes the user has only one partition (i.e.
only /dev/sd0a).  It will fail on systems like mine which has separate
/ and usr partitions.  What will go wrong if it blindly mounts
/dev/sd${r}g on /usr?  I don't think it causes that serious errors.

Btw, I lost my BETA-0 {dev,misc}.tar files so I tried to get them
again from cray-ymp.  But, you know, BETA-0 directory is no longer
readable by anonymous users.  Could you make it readable by anonymous
users again?