Subject: BETA 0 installation success!
To: None <>
From: chas williams <>
List: macbsd-development
Date: 05/01/1994 09:32:45
well this saturday i decided to try to install BETA 0--it works.  My
machine is plain jane: Mac IIcx, 8M ram, Apple 8-bit video card.

A few gotchas i seemed to experience. 

o) as mentioned by the previous poster using an SE/30, dev.tgz is "short".  
   to get around this, i unpacked it locally (on my sparc) and used
   MAKEDEV to build some device nodes and made a new dev.tgz (YMMV)

   Of course, i only needed to do this since, i completely repartitioned my
   drive (i wanted to change the size of my swap parition)

o) for my first boot, i did as the readme suggested and booted multi-user.
   i received the following message:

   /etc/rc: Can't open /etc/rc 

   My machine then spawned a shell as root.  So I configured by hand by
   doing the following:
   % mount -u /dev/sd2a /		# to get r/w permission
   % cd /etc
   % cp rc.distribution rc
   % cp fstab ; vi fstab

   Boots to multi user worked fine after this.   I looked in the tar files
   for a "configuration" /etc/rc script but did not see anything of the kind.
   What did i do wrong? (in case it matters, i did not install usr.share.doc,, usr.share.dict,

o) i tried to setup SLIP.  The names for ser0, and ser1 have changed to tty0
   and tty1.  I went to /dev and did the appropriate MAKEDEV's and rebooted.
   While rebooting, i noticed that ttyflags (in /etc/rc) spewed many strange
   messages.  Well, i then tried to use cu to talk to my modem.  I received:
   % cu -l /dev/tty0 -s 19200
   cu: /dev/tty0 permission denied

   rather odd, since i am root!  i changed the device to be 660 and then cu
   was able to open the device.  But, any characters i typed did not seem to
   go to my modem--i.e. i didn't see the txd and rxd lights flash as i typed.

   Suspect of anything new, i commented out ttyflags -a in /etc/rc and rebooted.
   Now cu worked properly (i.e. like when i was running Alpha2), and I was able
   to get SLIP going (Hurrah!)

   what is ttyflags -a doing?  (maybe i should install the man pages)

o) both 1-bit and 8-bit moded worked for me as well for those that care.

o) oh yeah, and something funny is happening with halt.  When i issue halt,
   it gives me a strange message about not being able to set the battery
   backed clock (provides some strange diagnostic) and then seems to hang.
   i.e. it doesnt poweroff/reboot the mac.  is this new behavior?  am i too

All in all, it was pretty straight forward and worked (in fact, it was much
easier than changing the brakes in my car since i dont have to wash my hands
after installing macbsd)

--chas iii