Subject: SE/30 on ALPHA2
To: None <>
From: None <>
List: macbsd-development
Date: 01/24/1994 09:27:17
> 	I was having problems bringing up Alpha2 on an SE/30 similar
> to many others on this list: the boot sequence would freeze
> immediately after the disks were mounted, and none of the binaries
> from Alpha2 would run under the Alpha 35 system.  I had decompressed
> the Alpha2 system using MacCompress, so I read the message from Greg
> Becker about the dangers of decompressing with the CR <--> LF menu
> option set.  I examined the decompressed files, however, and found
> that they all still had both CR and LF byte values in them, which
> would seem to indicate that neither had been converted to the other.

Its even worse than this.  MacCompress did promise that it would detect the
type of compressed file and decompress properly (at least in the documentation
I read and it has always worked for me in the past).

The absolutely sinister thing is that when the "MacCompress" option is selected
in the menu, the "CR <-> LF" option shows gray "not selected".  However, when
you select "Unix Compress", this setting magically comes to life "selected". I
guessed that the cr/lf translation was being performed silently behind my back.

When I re-expanded all files with this setting off and installed them,

Yes, it worked like a bought one.  I finally had (with some minor tweaks) a
working ALPHA2 on the SE/30

I think this is a warning that should go into the FAQ.  I am staggered that the
corruption was enough to hang the system "after a while" but not enough to stop
it from starting.

Also, could whomever picks up the installer add a couple of new features.
Either (a) do the decompression automatically
and/or (b) print a 'sum' like checksum of the .tar files installed (the whole
file, not each seperate component.  that way, a list can be kept alongside the
archives and this sort of corruption becomes harder to sneak through..)