Subject: Problems installing MacBSD
To: None <m68k@NetBSD.ORG>
From: Bernd Machenschalk <>
List: m68k
Date: 03/05/1996 17:23:42

Some months ago I installed MacBSD 1.0 successfull on my IIx.

After a lot of changes in my system configuration mostly concerning my HDs
I noticed that there is NetBSD 1.1 and tried to install a completely new
system, the 1.1 distribution I found on the NetBSD mirror in Germany.

I made room on the last 200 Megs on my new IBM 31080 (1G) with the HDT
Hard Disk Toolkit 1.5.1 (Version 1.3 worked fine for NetBSD 1.0)
and installed base11, etc11 and a kernel called
netbsd11 (dated Nov 28). The message I got was: 

	Bootstrapping the pmap system
	Failure in BSD boot. nextpa=0x106000, high[0]=0x100000
	panic: You're hosed!

	Stopped at: _Debugger+0x6:unlk a6
	db> unexpected trap; vector offset 0x0 from 0x739c0000
	fpu_emulate: bad opcode 0xffff


I then installed my old netbsd10 kernel and got a little further, up to
fsck with the message:


I found out that I only had that problem if I used the upper half of the HD.
Any ideas why? I have no such problems with HFS partitions or A/UX. 

Anyway: As the netbsd11 kernel doesn't run on my machine and the netbsd10
still has the keyboard hang bug (KHB), where can I get a kernel that runs on my
machine and might allow me to build a kernel for myself? I tried it with the
1.0 in the old days, but due to the KHB and the very slow SCSI I gave it up.

Summary : Whats wrong with the harddisk(-interface)?
	  Where do I get a working recent kernel?

My Hardware:
Mac IIx, extended keyboard, one-button-mouse, one FD
HD: IBM 31080 (SCSI ID 0), Quantum Trailblazer 850 (ID 1)
Formac Prograph 19" B&W NuBus system (1024x768), Apple 8*24 on NEC 4FG,
Mac286, Assante NuBus Ethernet card