Subject: Re: loss root passwd after install amd64cd.iso from NetBSD-daily/HEAD/200712180002Z
To: Current Users <>
From: Sarton O'Brien <>
List: current-users
Date: 12/21/2007 10:02:07
Stephen Borrill wrote:
> On Thu, 20 Dec 2007, abutter gao wrote:
>> System hang after printing "umount file systems... done", so I had to
>> reboot my HPV3183 by the power button. But I tried to input the
>> password but couldn't login anymore, and I bet I didn't take the wrong
>> password.
>> so I think perhaps the sysinst didn't save the password to file
>> really, or there was something wrong else.
> Yes, I've seen that on a -current from a couple of days ago. I 
> couldn't log in as root on a fresh install. I couldn't login on any 
> account with no password. The message was odd too as it was reporting 
> "foo" as the terminal name instead of ttyE0 or console.
> I found that running postinstall fixed it though.
> I also saw that MAKEDEV failed on bio during installation, so this 
> perhaps aborted the install.
foo is not a secure terminal therefore won't allow root logins .... 
there should be nothing wrong with how the root password is actually stored

If you managed to install and set up ssh before rebooting, you should 
still have access ... assuming you have a user attached to wheel.