Subject: Re: etcupdate and atf-run.hooks
To: Sarton O'Brien <>
From: Steven M. Bellovin <>
List: current-users
Date: 12/19/2007 20:59:27
On Thu, 20 Dec 2007 12:27:02 +1100
"Sarton O'Brien" <> wrote:

> Hi all,
> For the first time I ran into:
> make: don't know how to make atf-run.hooks. Stop

Yup -- I saw that, too.
> Which I've since realised can be overcome with 'etcupdate -s etc.tgz'
> but ... when I ran into the problem I issued the command again and it
> prompted to continue, which I said yes to.
> Not being a system I care about, I allowed it to update most things
> blindly. It wasn't until I actually read what I was answering yes to,
> that I realised it was replacing files it ought not to
> (pwd.db/utmp/lastlog etc).
> That aside, I fixed most of what problems had been created but when
> attempting to log into the console (this is a domu) as root, I get:
> Login incorrect or refused on this terminal.
> pam_securetty[344]: LOGIN root REFUSED ON TTY foo
> login: 1 LOGIN FAILURE ON foo
> So 'console' has now changed to foo, which is curious and I don't
> know where to change this back. I'd imagine if foo was secure it
> would log in just fine but I haven't tested.
I was trying to figure out where /dev/foo came from -- I didn't think
I'd created it (though I conceivably could have).  Just remove it and
that will work fine.

		--Steve Bellovin,