Subject: broken ath(4) incoming unicast WEP in current?
To: None <>
From: Greg Troxel <>
List: current-users
Date: 11/25/2007 19:52:38
I built -current from sources updated 1558 UTZ on 11/24.  I installed
this on a Thinkpad 600E, and used GENERIC.NOACPI because the machine is
from 1999 and has buggy ACPI.

The machine boots and runs ok, except that it cannot receive unicast
packets on 802.11.  I have an ath(4) card in cardbus, and have
previously been using that successfully as the only network interface.
Near this machine there is a commodity AP/firewall running as a bridge,
with WEP, and hooked up to that is another netbsd box.

I can see outgoing packets from the 600E arriving at the other box, and
replies going back.  Running tcpdump on the 600E, I can see outgoing
packets, incoming broadcasts, and incoming bridge control packets.  At
times when the expected replies should arrive, I see packets that look
like total gibberish, as if they were not decrypted.  So I suspect that
somehow WEP decryption is not being applied to unicast packets.

The previous build that worked (that I tried) was October 24th or so.  I
tried a build from early November, and it crashed on boot with a
backtrace that made me think it was trying some ACPI operations.

Is anyone else seeing anything like this?