Subject: Inverted boot problem for a Mac Mini
To: NetBSD-current Users <>
From: Johan Ihren <>
List: current-users
Date: 11/06/2007 01:19:04
Hash: SHA1

I have a Mac Mini that really should run MacOSX. But I wanted to try  
out NetBSD on it so I swapped out the MacOSX disk to a safe shelf and  
put in a raw disk instead.

Test #1: install MacOSX on the raw disk from distribution media. No  
problem, worked like a charm (I just wanted to verify that I could  
reinstall the commercial stuff in case the original disk went south  
at some point).

Test #2: install NetBSD 4.0 RC-something. Worked like a charm.  
Everyone happy.

Once I'm happy everything is working as planned I revert back to  
MacOSX by reinstalling from Mac distribution media. This is where the  
problems begin.

Problem #1: the Mac install DVD (this is a MacOSX10.4.7 Tiger DVD) is  
no longer recognized as "bootable". The box just complains about "No  
bootable device -- insert boot disk and press any key".

Problem #2: inserting something else and pressing any key doesn't do  
much at all. In fact NO KEYS WHATSOEVER have any effect at all in  
communicating with the "unbooted" Mini. There are various magic  
keypresses for "zapping the PRAM" (cmd+option+P+R), "boot from  
CDROM", etc, etc. None of these have any effect at all.

Problem #3: reinserting the original, pristine, MacOSX hard disk  
produces the same "No bootable device -- insert boot disk and press  
any key" message as the other alternatives (so much for beliving  
you're safe as long as you don't mess up the original disk).

However: the box still boots NetBSD just fine from the hard disk.  
And, more interesting: it boots the NetBSD install CD just fine, too...

So, in short: Doesn't listen to the keyboard at all during boot,  
doesn't boot Mac media (HDD or DVD) but does boot NetBSD media (HDD  
or CD). I'm stuck with NetBSD ;-)

When I've tried asking around in Mac circles for suggestions I mostly  
get back a bit of Mac confusion "I don't think you CAN run NetBSD on  
a Mini...." ("You don't understand my problem: I cannot run anything  
BUT NetBSD on this Mini now..."). Anyways, no ideas beyond "zapping  
the PRAM" (which doesn't work apparently) have been forthcoming,  

My own wild guess is that knowing that Intel Macs use EFI (that I  
don't understand), somewhere something has happened that has flipped  
the Mini into some sort of BIOS-compatibility mode and in that mode  
BIOS booting works just dandy, but the Mac install media doesn't  
taste right. But I don't know.

I would really, really appreciate some creative insight into both  
what has happened here and suggestions for how to backtrack.


Johan, stuck in a corner.
Version: GnuPG v1.4.5 (Darwin)