Subject: unable to dump kernel core
To: None <,>
From: Antti Kantee <>
List: current-users
Date: 11/04/2007 22:26:13

For some time now I've been unable to get a kernel coredump from a system.
At first I thought the system merely hung without panicking, but recently
I discovered that it was in fact either "syncing disks" or "dumping to .."
which made the system hang (this was fairly difficult to see from X).

I tried it in qemu also with the same result.  It seems that the I/O
for reading the swap device disklable never finishes and it is waited
for indefinitely:

#0  biowait (bp=0xcacd1a78) at ../../../../kern/vfs_bio.c:1351
#1  0xc03218c1 in read_sector (a=0xcac45808, sector=0, count=1)
    at ../../../../kern/subr_disk_mbr.c:115
#2  0xc0321907 in scan_mbr (a=0xcac45808, actn=0xc0321e1a <look_netbsd_part>)
    at ../../../../kern/subr_disk_mbr.c:143
#3  0xc0321c83 in readdisklabel (dev=11, strat=0xc0346267 <wdstrategy>, 
    lp=0xc096b600, osdep=0xc096b400) at ../../../../kern/subr_disk_mbr.c:293
#4  0xc034772c in wdgetdisklabel (wd=0xc096c800)
    at ../../../../dev/ata/wd.c:1079
#5  0xc0347110 in wdopen (dev=9, flag=0, fmt=24576, l=0x0)
    at ../../../../dev/ata/wd.c:944
#6  0xc0348652 in wdsize (dev=9) at ../../../../dev/ata/wd.c:1537
#7  0xc0324472 in dumpsys () at ../../../../arch/i386/i386/machdep.c:1110
#8  0xc0323fa0 in cpu_reboot (howto=256, bootstr=0x0)
    at ../../../../arch/i386/i386/machdep.c:853
#9  0xc0284dac in panic (fmt=0xc03dadf2 "trap")
    at ../../../../kern/subr_prf.c:246

Does anyone have a clue?  I can't exactly say when the last working
-current dumping date was, but it was month(s) ago.  Does anyone even
have similar problems?  Some people have reported that kernel coredumps
work just fine for them.

Antti Kantee <>                     Of course he runs NetBSD                
    "la qualité la plus indispensable du cuisinier est l'exactitude"