Subject: Re: Undefined PLT symbol "__stat30" (symnum = 44)
To: Kenneth Freidank <>
From: Tom Spindler <>
List: current-users
Date: 09/25/2007 18:48:46
On Tue, Sep 25, 2007 at 09:07:30PM -0500, Kenneth Freidank wrote:
> 1) I just rebuilt the toolset on box A.  Box A is running 4.99.19.  I 
> even used the -m flag to make no mistakes.
> 2) I telnetted to box B and changed to root and NFS mounted all my 
> directories.
> 3) TRY1:  From telnet session on box B, I tried to install new 4.99.31 
> userland.  Same problem and error.  Remember box B has 4.99.31 kernel 
> with old 3.1 userland.
> 4) TRY2:  From telnet session on box B, I then restored the old 3.1 
> kernel on box B, i.e. back to original 3.1 config with GENERIC.   I 
> remounted directories, then tried to install new 4.99.31 userland...same 
> problem

There's your problem. The tools/ bins are built for 4.99.19 userland
(and specifically, with the 4.99.19 libs) - and won't work with a 3.1
userland. tools on box B, and then the install should work; just nuking
nbmake is necessary, but might also be sufficient. Doubt it, though.