Subject: Undefined PLT symbol "__stat30" (symnum = 44)
To: None <>
From: Kenneth Freidank <>
List: current-users
Date: 09/25/2007 18:53:30
I get a build error about the toolchain that I don't think I should be 
getting.  Can anyone lend a hand?

I just built 4.99.31 (from tar files labeled 9/10/07) on box A running 
4.99.19.  My target is box B.

My intent was to not install anything, just build.  (did I just update 
box A and didn't realize what I did?)
   ./ -O /usr/obj -T /usr/tools -D /usr/destdir/ -x -U distribution
   ./ -O /usr/obj -T /usr/tools -D /usr/destdir/ -x -U -u release

I then built my target kernel.
   ./ -O /usr/obj -T /usr/tools -D /usr/destdir/ -x -U -u 

No errors.  So far, so good.

Box B was running the factory distribution 3.1.

On box B, I NFS mounted all my /usr/src, /usr/xsrc, /usr/obj, 
/usr/tools, /usr/destdir connecting to their source on Box A.

I copied the kernel from box A to B.  Rebooted box B and it worked!

When I tried to install userland, that is when I got my failure.

t600# pwd
t600# ./ -O /usr/obj/ -T /usr/tools/ -D /usr/destdir/ -U -x 
===> command: ./ -O /usr/obj/ -T /usr/tools/ -D 
/usr/destdir/ -U -x install=/
===> started: Tue Sep 25 08:17:46 EST 2007
===> NetBSD version:   4.99.31
===> MACHINE:          i386
===> MACHINE_ARCH:     i386
===> Build platform:   NetBSD 4.99.31 i386
===> HOST_SH:          /bin/sh
/usr/tools/bin/nbmake: Undefined PLT symbol "__stat30" (symnum = 44)

ERROR: raw_getmakevar TOOLCHAIN_MISSING: /usr/tools/bin/nbmake failed