Subject: X11 not building these days?
To: None <>
From: Peter Seebach <>
List: current-users
Date: 09/03/2007 23:33:45
So, I did something (I don't even know what, exactly -- just another
reminder not to administer computers without caffeine), and I blew up
my X on my desktop.  So, I tried to rebuild it.  And tried again.
I'm stumped.  If I have MKX11=yes, fails in general.  So I
set it to no, built, made sure I have current kernel and userland, and
tried again.  No luck.

The symptoms seem to be that various headers that are part of distributions
are not copied into the build directory.  So, for instance, expat fails
because xmltok.c needs xmltok_impl.c, but that never got copied.  I may
be doing something obvious wrong here.

Most obviously, if I want to build X, what are the relevant build
variables in mk.conf?  'man mk.conf' doesn't mention them.  The other
question, I guess, would be whether this is normally working; if it is
for other people, then I must have done something wrong.  If it's not,
then at least it's not my fault.  :)