Subject: compat_linux/i386 broken for x11 programs
To: None <>
From: Markus W Kilbinger <>
List: current-users
Date: 06/04/2007 10:02:25

-current source changes between 2007-06-02 06:00 UTC and 2007-06-03
18:00 UTC seem to break compat_linux on both of my i386 machines for
x11 programs (acroread, firefox-bin):

  $ acroread
  acroread: Fatal IO error 22 (Invalid argument) on X server :0.0.

Reverting to a kernel based on -current sources directly before
2007-06-02 06:00 UTC makes these linux binaries run fine.

Does anybody else see this?