Subject: Re: puffs/refuse in 4.0?
To: Alistair Crooks <>
From: Antti Kantee <>
List: current-users
Date: 05/17/2007 17:46:29
On Thu May 17 2007 at 12:25:37 +0100, Alistair Crooks wrote:
> On Wed, May 16, 2007 at 02:38:48PM -0400, Andreas Wrede wrote:
> > Would it be possible to pullup the current state of puffs/refuse to  
> > 4.0?  What's currently in 4.0 is the state of development at the time  
> > of the 4.0 re-branch and is not very useful, compared to -current. It  
> > would be a pity to have to wait for 5.0 to see puffs/refuse support  
> > in NetBSD.
> It's up to Antti, really, since librefuse just sits on top of
> libpuffs.  I don't want to speak for him, but, in the past, because of
> the changing nature of the interface, he's been reluctant to do this;

No, I was reluctant to make it build by default because of the changing
nature, so that people using it would realize they may need to rebuild
everything if they update a portion of the source tree.

> maybe he'll reconsider now that it looks like things are
> solidifying somewhat.

riiight ... ;)

Anyway, it's not up to me, it's up to whoever wants to do the work to
get it into 4.x and deal with whatever issues that creates.

Antti Kantee <>                     Of course he runs NetBSD                
    "la qualité la plus indispensable du cuisinier est l'exactitude"