Subject: No nonexistent/bin/nbmake, needs building.
To: None <>
From: Jeremy C. Reed <>
List: current-users
Date: 04/05/2007 15:27:42
I used ./ -U tools kernel=JCR20070405 
and it failed later due to some kernel option problems. (So I fixed.)

Then I ran:

./ -U kernel=JCR20070405

and it did:

glacier:/usr/src$ ./ -U kernel=JCR20070405           
===> command: ./ -U kernel=JCR20070405
===> started: Thu Apr  5 15:18:58 CDT 2007
===> NetBSD version:   4.99.16
===> MACHINE:          i386
===> MACHINE_ARCH:     i386
===> Build platform:   NetBSD 3.99.24 i386
===> HOST_SH:          /bin/sh
===> No nonexistent/bin/nbmake, needs building.
===> Bootstrapping nbmake
checking for sh... /bin/sh
checking for gcc... cc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for executable suffix... 
checking for object suffix... o

I looked in the BUILDING file about nbmake. But still this is unclear. 
And I have had this problem before (and reported it before I think).

What is the purpose of rebuilding make over and over again?

In fact, I don't want any tools made as I am running current and building 
a current kernel. It is a waste of time.

I also tried:

./ -U -T tools kernel=JCR20070405

But same problem. (I have tools there but no nbmake there.)

Then I did:

./ -U -T /usr/obj/tooldir.NetBSD-3.99.24-i386 kernel=JCR20070405

What is the purpose of figuring this out manually? Can't be 

  Jeremy C. Reed