Subject: Re: After newlock2 merge: Different pthread behavior for userland programs?
To: Andrew Doran <>
From: Markus W Kilbinger <>
List: current-users
Date: 03/11/2007 17:57:02
>>>>> "Doran" == Andrew Doran <> writes:

    >> After updating the whole machine to the newlock2 base (kernel +
    >> userland) asterisk seems to startup fine, but does no longer
    >> accept (all) incoming phone calls!?

    Doran> Hi, Thanks for the problem report.

    Doran> If you could file a PR about this it would be ideal. A good
    Doran> first step for diagnostic the problem would be to attach to
    Doran> the process responsible for handling incoming calls with
    Doran> "ktrace -di -p $pid", and make available the ktrace.out
    Doran> file that is produced (or relevant excerpts from kdump -R,
    Doran> afterwards).

Sorry, I had no time so far to do some testings (too many NMI's :-/),
but today I noticed something else/strange: My qube2 ran in the
(known) situation that asterisk no longer accept calls (in these
situations asterisk says: 'Mar 11 10:43:11 WARNING[587] app.c: No
audio available on SIP/0800615243-00789000??').

So I tried to stop the running asterisk process und restarted it,
which seemed to work (the process vanished from the process list and
re-appeared after its re-starting). Now the big 'but': The machine was
still not able to accept calls!? Repeating the asterisk's stop/restart
procedure didn't help anyway. Only rebooting the whole machine made
asterisk (initially) accepting calls again. How can this be!?

Which 'relicts' of a terminated program can survive its restart? Any
other idea for this 'behavior'?