Subject: Re: pam_radius seems to be completely broken in NetBSD-3.x, probably everywhere???
To: Adrian Portelli <>
From: Brian Buhrow <>
List: current-users
Date: 02/24/2007 11:30:39
	Yes, this is the problem I'm having.  The reason for the error is
because the module is missing a bunch of function entry
points necessary to interface with the pam api.  My project precludes me
from installing an additional third party package, so I'll fix the problem,
or try to.  When I have a fix, I'll reply to this bug, and perhaps it will
get fixed soon.

On Feb 24,  6:14pm, Adrian Portelli wrote:
} Subject: Re: pam_radius seems to be completely broken in NetBSD-3.x, proba
} Brian Buhrow wrote:
} > 	Hello.  I am working on a project which uses various pam modules for
} > various kinds of authentication.  In testing the library, I
} > notice that it's missing most of the entry points necessary for the main
} > module to load it.  This state of affairs appears to have existed since the
} > package was imported from FreeBSD.  Note that this doesn't prevent it from
} > building, but it does prevent it from being loaded at run time by the pam
} > dynamic loader.
} > 	I think I know how to fix this, and I'll open a problem report when I
} > have a working fix, but I wanted to write and ask if anyone has used the
} > pam_radius module under NetBSD, and, if so, howyou made it work?
} > -thanks
} > -Brian
} > 
} Hi,
} I bumped into some issues with pam_radius a little while ago and
} documented them here:
} I ended up importing and using security/pam-radius instead which suits
} my needs well.
} adrian.
>-- End of excerpt from Adrian Portelli