Subject: Making sounds? :)
To: None <>
From: Paul Goyette <>
List: current-users
Date: 12/27/2006 17:53:34
Well, I finally decided to see if I could make my NetBSD machine play
a CD.  Following through various man pages, I tried to run cdplay.

If I simply tell it to "play" it acts like it's doing it, but nothing
comes out of the speakers.  If I first tell it to use "digital transfer
mode" and then "play" it starts spewing messages on the console:

 	viaide0:0:0: lost interrupt
 		type: atapi tc_bcount: 11760 tc_skip: 0

at a rate of about 1 per second;  still no audio.

Any clues?

Relevant dmesg stuff:

auich0 at pci0 dev 4 function 0: nForce4 AC-97 Audio
auich0: interrupting at ioapic0 pin 22 (irq 11)
auich0: ac97: Avance Logic ALC850 codec; no 3D stereo
auich0: ac97: ext id 9c6<AC97_23,LDAC,SDAC,CDAC,SPDIF,DRA>
audio0 at auich0: full duplex, independent
cd0 at atapibus0 drive 0: <LITE-ON DVDRW SHW-160P6S, , PS08> cdrom removable
cd0: 32-bit data port
cd0: drive supports PIO mode 4, DMA mode 2, Ultra-DMA mode 4 (Ultra/66)
cd0(viaide0:0:0): using PIO mode 4, Ultra-DMA mode 4 (Ultra/66) (using DMA)

|   Paul Goyette   | PGP DSS Key fingerprint: |  E-mail addresses:   |
| Network Engineer | FA29 0E3B 35AF E8AE 6651 |   |
|                  | 0786 F758 55DE 53BA 7731 | |