Subject: Re: bcm5754 support
To: Havard Eidnes <>
From: Sarton O'Brien <>
List: current-users
Date: 12/21/2006 09:36:39
Just thought I would quickly note that the latest release of OpenBSD suppor=
the bcm5754. There seems to be issues with the FreeBSD driver with incorrec=
detection, though this could have been rectified by now.

Unfortunately I can't switch OS as I am running Xen, unless I switch to=20
linux ...


On Thursday 21 December 2006 06:24, Havard Eidnes wrote:
> > Can anyone tell me if the bcm5754 gigabit ethernet adapter is
> > supported under current?
> It doesn't look like it, unfortunately; the bge_products array in
> the driver still doesn't mention the 5754.
> I've looked over in FreeBSD's repository, and the change to
> support 5754, 5755, and 5787 does not look terrifyingly large,
> but there's always the chance there's some earlier driver change
> we have not picked up that this change depends on...  If you
> want, I can probably make a patch for you to try?
> Regards,
> - H=E5vard