Subject: Strange network problem with buffer space, huge lag, and so on
To: None <>
From: M Graff <>
List: current-users
Date: 10/25/2006 22:13:39
Hash: SHA1

My configuration is as follows:

	vlan13 is my local wire.  This hosts the machine I am running cvs
update on.

	vlan9 is my external interface.  This includes the outgoing cable
modem.  I have two addresses, one static (used only to talk to the
cable modem itself) and one dynamic (the one the cable system gives me.)

When I run a "cvs update" on a host on vlan13, and a ping from my router
box, I get this sort of situation:

64 bytes from icmp_seq=18 ttl=64 time=4.656 ms
64 bytes from icmp_seq=19 ttl=64 time=0.810 ms
64 bytes from icmp_seq=20 ttl=64 time=0.578 ms
64 bytes from icmp_seq=21 ttl=64 time=4.367 ms
64 bytes from icmp_seq=22 ttl=64 time=448.628 ms
64 bytes from icmp_seq=23 ttl=64 time=3.969 ms
64 bytes from icmp_seq=24 ttl=64 time=698.421 ms
64 bytes from icmp_seq=25 ttl=64 time=473.774 ms
64 bytes from icmp_seq=26 ttl=64 time=327.393 ms
64 bytes from icmp_seq=27 ttl=64 time=1289.104 ms
64 bytes from icmp_seq=28 ttl=64 time=574.265 ms
64 bytes from icmp_seq=29 ttl=64 time=100.087 ms
64 bytes from icmp_seq=30 ttl=64 time=0.569 ms
64 bytes from icmp_seq=31 ttl=64 time=658.741 ms
64 bytes from icmp_seq=32 ttl=64 time=741.042 ms
64 bytes from icmp_seq=33 ttl=64 time=351.279 ms
64 bytes from icmp_seq=34 ttl=64 time=2.938 ms
ping: sendto: No buffer space available
64 bytes from icmp_seq=35 ttl=64 time=1195.469 ms
64 bytes from icmp_seq=37 ttl=64 time=348.838 ms
64 bytes from icmp_seq=38 ttl=64 time=0.539 ms
64 bytes from icmp_seq=39 ttl=64 time=671.998 ms
64 bytes from icmp_seq=40 ttl=64 time=521.078 ms
64 bytes from icmp_seq=41 ttl=64 time=650.012 ms
64 bytes from icmp_seq=42 ttl=64 time=529.919 ms
64 bytes from icmp_seq=43 ttl=64 time=0.545 ms
64 bytes from icmp_seq=44 ttl=64 time=671.286 ms
64 bytes from icmp_seq=45 ttl=64 time=514.058 ms

Note that is local to me.

There is a VLAN capable switch between me and the modem, and me and the
vlan13 hosts.  Until recently, however, I have had what is more or less
no problem with this, and now I get no buffer space messages and HUGE
ping times.

I have tried this both with and without pf filtering and ALTQ queueing.
 I have to keep pf active, however, since it is needed for NAT.

Note that running CVS update on the ROUTER also does this sort of thing.
 It seems to happen only when CVS is sending files to the server.

Any ideas what I should look at to try to diagnose this?

Note however that I do NOT see this sort of lag on vlan13, when I ping
hosts...  It's all very strange.

- --Michael
Version: GnuPG v1.4.2.2 (MingW32)