Subject: Re: Help with HP NX6310
To: NetBSD-current Discussion List <>
From: Paul Ripke <>
List: current-users
Date: 10/19/2006 18:31:39
On Wed, Oct 18, 2006 at 03:08:05PM +0100, Chavdar Ivanov wrote:
> This all is being done under fresh -current, although the main problem
> described below shows its ugly head under 3.1b4. I probably should be
> asking -users, but let me try here first.
> I got a new (company, therefore not selected by me unfortunately)
> laptop some times ago - an HP 6310, as you have gathered from the
> subject line... It has got T2300 dual-core Yonah CPU, which I am
> strugling to get to work with MULTIPROCESSOR option. GENERIC.MP does
> not recognize the second core (as expected due to the ACPI),
> GENERIC.MPACPI  does not play game - it hard freezes just after the
> npx0 at acpi0 (PNP0C04)
> npx0: io 0xf0-0xff irq 13
> lines. The only save is to switch off the thing and start again -
> Ctrl-Alt-Esc does not do anything. I have tried to compile it with all
> the DEBUG options (no kdbg, as the machine does not have a serial
> port!) to no avail.

I have an ASUS P4P800-E motherboard with P4 CPU desktop system that
hangs after probing npx0, if:
- HT is enabled.
- ACPI is enabled.
- the system is warm booted (after a crash or normal reboot).

From a cold boot, it's fine. I'd always assumed it was a bug
with the BIOS not reseting hardware state properly. I'd started
looking into the issue, but gave up as it's my main NFS server,
build box, firewall, etc, etc, etc, and its 220 GB RAID5 array
takes an age to fsck and parity check if I don't get a clean

So, it's not just laptops. BTW, I was trying to debug the issue
with 3.0, and I haven't tried anything newer. It's on my todo
list to upgrade to 4.0, as soon as I find enough Round Tuits.

Paul Ripke