Subject: Re: Help with HP NX6310
To: Chris Tribo <>
From: Chavdar Ivanov <>
List: current-users
Date: 10/18/2006 22:49:55
On 10/18/06, Chris Tribo <> wrote:
> On Oct 18, 2006, at 11:26 AM, Chavdar Ivanov wrote:
> > On 10/18/06, Chavdar Ivanov <> wrote:
> >> This all is being done under fresh -current, although the main
> >> problem
> > ...
> >> The BroadCom BCM4401-B0 (bce) started to work OK
> >> after I included bmtphy in the GENERIC_LAPTOP configuration. The
> >> sound
> >> (azalia) also shows, but I still haven't tested any of it.
> >
> > The gremlin with the BroadCom appeared again - funny enough after I
> > booted into Windows XP to check if the sound was on. Now I am getting
> >
> > bce0: timeout disabling ethernet mac
> > bce0: timeout writing pkt filter ctl
> If if isn't already off, try disabling PXE/RPL/Netboot agent in the
> BIOS. At least with the 575x chips, I see problems where our bge
> driver doesn't properly tell the chip to disable the PXE/UNDI stack
> when the chip is reset.

PXE boot appears disabled in the BIOS.

> It almost always happens when warm rebooting
> from windows to NetBSD until I PXE boot or hard power off the system
> (unplugging it), and sometimes not even then.

That seems to be the case indeed. Will test it tomorrow.

> > when I try to up it again. It is probably an interrupt routing problem
> > - azalia0. wpi0 uhci1 and bce0 all use irq11.
> Yes, on the GX280, GX620 and Optiplex 745, there are about 6 devices
> on IRQ 11, NetBSD fails miserably with both APIC and non-APIC, ACPI
> and non-ACPI kernels. Linux works fine.
> > The sound worked after I increased the volume with
> >
> > mixerctl -w outputs.hp=200
> >
> > but only to the external output - couldn't figure out how to switch it
> > to the speaker (not that I will actually *use* the speaker, but there
> > you are).
> I don't know how well these new chips that use UAA bus (Universal
> Audio Architecture) work, I didn't even try it. Most of the time I
> couldn't even type because the USB controllers keep shutting down,
> and the NIC doesn't work so I was debugging over serial line.

Well, RS232 adapters nowadays are seen not that often - remember the
various MS/Intel etc. PC200x specs... I might get a USB-to-serial
adapter sometimes to use when testing some DNC connections, but that's
under Windows anyway; doubt it will be useful when debugging a kernel
with kgdb... Some other method is needed.

> I gave
> up when I couldn't even get a PCI ID for the new Broadcom chip
> committed.

I was happy enough when I heard the sound out of the headset... The
output of 'mixerctl -a -v' is tremendous - I can't make any sense of
all the devices...

Still no progress on the dual core with MULTIPROCESSOR. I will now go
through the paces of compiling the ACPI table in the kernel - but on unfortunately I could find the definition for a NX6325, not
mine NX6310 (the -25 is up to DualCore Turion, so the picture would be
completely different).