Subject: Re: -current/i386 hangs near pcic probe
To: None <>
From: Wolfgang S. Rupprecht <>
List: current-users
Date: 10/16/2006 13:29:53
Matthias Scheler <> writes:
> On Sun, Oct 15, 2006 at 12:31:10PM -0700, Wolfgang S. Rupprecht wrote:
>> I'm seeing a hang on a P-III Intel motherboard (AL440LX) with a
>> lightly edited version of the ACPI enabled GENERIC_MPACPI kernel.
> Did you try updating the BIOS or use MPBIOS? I had a lot of trouble
> with MPACPI and Windows 2000 on P-II motherboard while MPBIOS worked
> fine with Windows NT 4.0 without problems.

I just checked. The last bios was Apr 20, 1999 bios (version P14),
which is the one I'm running.

I was interested in running ACPI so I could intercept the power-switch
press and do a graceful shutdown.

> It took the motherboard manufactorers quite a while to get ACPI
> working properly.

I believe it.  A current GENERIC/i386 kernel has no problems booting,
so it does seem to be ACPI related.  The mobo also worked with this
June's ACPI kernel, so whatever the problem is, it was just exposed
recently.  Oh well, I suppose this machine was bound to fall off the
well-supported list sooner or later.

I just cleared some of the CMOS state from the bios setup screens.  In
the past this has resulted in slight changes in interrupt assignments.
After I did that the MPACPI kernel did boot, but later when running
user code I got a few disk error messages every couple of minutes.
These didn't happen before or under the GENERIC kernel.  Oh well, back
to GENERIC it is.

Wolfgang S. Rupprecht