Subject: Re: can't mount a umass device.
To: None <>
From: George Georgalis <>
List: current-users
Date: 10/01/2006 21:39:38
On Mon, Oct 02, 2006 at 11:13:06AM +1000, Paul (NCC/CS). wrote:
>Matthias Scheler wrote:
>> On Sat, Sep 30, 2006 at 06:11:06PM +1000, Paul (NCC/CS) wrote:
>> > I am wondering if anyone, particularly with usb experience can help me.
>> > I am trying to mount a new 5th generation ipod but the 3.0 code is not
>> > coping.
>> Can you try a NetBSD 3.1_RC3 kernel please? There have been various
>> fixes to the ehci(4) driver since NetBSD 3.0 was released.
>>         Kind regards
>> --
>> Matthias Scheler                       
>Hi Matthias,  others,
>- for this kernel release would the following tag be correct?
>   cvs checkout -r netbsd-3-1-RC3 -P src

I find this file handy to understand cvs tags...

you can probably use netbsd-3 that will track RCx
until 3.1 comes out, then you can use netbsd-3-1
or ...

>- what could I put if I only wanted the kernel sources?

Looks like you need all of src, eg cannot 
just download src/sys

>- lastly when it's downloaded what file could I check to
>read and confirm the version please?

every directory has a CVS/Tag file, also see
CVS/Entries for the tag on each file.

cd /usr && cvs checkout -r netbsd-3 -AP src

or if you got another tag already.

cd /usr/src/ && cvs -q update -dP -r netbsd-3 .

cvs doesn't need to download everything it will
just patch existing files on the fly.
which sounds like what you want.

// George

George Georgalis, systems architect, administrator <IXOYE><