Subject: Re: [Fwd: [Fwd: viaide problem with 4.0_BETA]]
To: Teemu Rinta-aho <>
From: Manuel Bouyer <>
List: current-users
Date: 09/29/2006 12:36:21
On Thu, Sep 28, 2006 at 10:57:49PM +0300, Teemu Rinta-aho wrote:
> Manuel Bouyer wrote:
> > On Tue, Sep 19, 2006 at 11:14:34AM +0300, Teemu Rinta-aho wrote:
> >> Hi! Thanks for the reply.
> >> 
> >> It doesn't hang at all, it just gets stuck in printing those 
> >> messages. It finds both of the (SATA) drives. I remember having had
> >>  a similar problem with other machines during the days I've been 
> >> using NetBSD... So I'm quite sure it's fixable :-)
> >> 
> >> What next? Try old versions of viaide.c and see where the problem 
> >> disappears?
> > 
> > Yes, and also compare interrupts allocation between working and 
> > non-working kernels.
> Well, I got a hint in e-mail from Nir Mor to disable APIC from the BIOS.
> I have been looking at the BIOS settings earlier, but they
> didn't help. I had tried everything, except enabling the
> IDE channels. I have had them disabled, as I don't have
> any IDE drives, only SATA. Well, it solved the problem
> for me. When I have *both* unused IDE channels enabled,
> there are no lost interrupts, but even if I disable
> one of them, I get lost interrupts.
> Not looking at the code at all, I have no idea whether this is
> a bug in the hardware or in the code - or in the BIOS user
> interface - letting me disable "very important" devices :-)

I don't think it's the code: IDE and SATA channels are presented as
independant controllers to the OS. I guess the BIOS is doing something
strange here ...

Manuel Bouyer, LIP6, Universite Paris VI. 
     NetBSD: 26 ans d'experience feront toujours la difference