Subject: Re: Bluetooth Imported.
To: Iain Hibbert <>
From: Andreas Gustafsson <>
List: current-users
Date: 07/14/2006 10:08:07
Iain Hibbert wrote:
> Hi,
>    Thanks to gdamore@, my Bluetooth work so far is imported.. currently it
> is enabled in GENERIC and GENERIC_LAPTOP kernels for i386 only but it
> should work on any platform that supports USB [ubt(4)] or PCMCIA [bt3c(4)]

This is excellent!  Many thanks to everyone involved.

>    I would be pleased to hear of success stories (and less pleased for any
> failures :) or any comments or questions - I currently read tech-kern,
> tech-userlevel and current-users.

Here's a success story: using a no-name USB Bluetooth adapter
(vendor 0x1131 product 0x1001, rev 1.10/3.73), I successfully paired
with my Ericsson t39m GSM phone and made a working GPRS connection.

I couldn't have done it without the HOWTO; hopefully it will be
included somewhere in the NetBSD distribution or featured prominently
on the NetBSD web site.

I haven't tried a headset or HID yet.

Some minor problems encountered along the way:

 - I upgraded by unpacking distribution sets built from -current as of
   July 4 and running postinstall.  I had hoped postinstall would
   create and populate the /etc/bluetooth directory, but it didn't;
   I had to do it by hand.

 - The HOWTO contains the example command "btpin -a phone -a 334323";
   I guess the second "-a" should be a "-p".

 - When I tried "cu -l /dev/ttyp9" as suggested in the HOWTO, the
   connection broke as soon as I typed a character:

     $ cu -l /dev/ttyp9

     Lost carrier.

   However, invoking rfcomm_sppd from pppd worked fine.

Andreas Gustafsson,