Subject: Re: Call for testers: i386 ACPI suspend/resume support
To: None <>
From: Takahiro Kambe <>
List: current-users
Date: 06/23/2006 11:42:29
In message <>
	on Sat, 17 Jun 2006 21:37:28 -0300 (ADT),
	"Jared D. McNeill" <> wrote:
>    * Make and model of your laptop.
Panasonic CF-R5K

>    * Full dmesg.
>    * Using sysutils/pciutil, the output of 'lspci -xxx' before and after
>      suspend/resume.
I've put these ouput into:

>    * Did it resume and (mostly) work? Did it resume but the display adapter
>      didn't re-initialize?
o I'm running pkgsrc/x11/xorg-server for "Intel 82945GM/PM/GMS
  Integrated Graphics Device".  X server dies when resumed.  Switching
  wscons to VGA mode console before suspend works.


o After resume, acpiacad(4) don't detect AC adapter's status any more.

>    * If you have resumed, do any device drivers no longer work?
o Unrecognized wireless LAN device gone after resume.

Intel PRO/Wireless LAN 3945ABG Mini-PCI Adapter (miscellaneous network, revision 0x02) at pci2 dev 0 function 0 not configured

  After resume it isn't displayed with lspci or rebooted Windows XP
  until completely power off.

o I don't test PC card slot but USB seems to works after resume.

o A sample dmesg ouput suspend and resume.


acpi0: entering state 3
pckbd0: suspending...


pckbport: command timeout
pckbd_disable: command error
acpi0: good morning!
pckbd0: resuming...
pms0: pms_synaptics_resume: reset on resume 0 0xaa 0x00
ehci0: BIOS has given up ownership
atabus0: resuming...
wd0a: channel reset writing fsbn 131120 of 131120-131131 (wd0 bn 23200460; cn 23016 tn 5 sn 17), retrying
acpi0: resuming
wd0: soft error (corrected)

Takahiro Kambe <>