Subject: Re: issues with 3.99.21 on SUN x4200
To: None <>
From: Jonathan A. Kollasch <>
List: current-users
Date: 06/16/2006 16:30:21
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Fri, Jun 16, 2006 at 10:48:49PM +0200, Klaus Heinz wrote:
> Hi,
> I had a short opportunity to boot a SUN x4200 (16GB RAM) with a NetBSD/i3=
> snapshot (HEAD/200606080000Z/i386/installation/cdrom/boot.iso).
> I preferred i386 over amd64 because I thought this would show the fewest
> problems...
> Issues on this machine:
>  Memory:
>   Obviously NetBSD did not recognize the whole 16GB RAM:
>   WARNING: skipping large memory map entry: 0x100000000/0x300000000/0x1
>   ...
>   total memory =3D 3967 MB
>   avail memory =3D 3889 MB

You shouldn't expect to even get this much.  AFAIK NetBSD does not
support PSE36.  Usually there is a 0.5GiB memory hole somewhere,
so you should only be seeing 3.5GiB of RAM.  If you want the RAM
run amd64.

>  Clock:
>    I do not have the slightest idea what this means:
>    RTC BIOS diagnostic error 2
>  CPU:
>   why does it say "Unknown K7"?
>   cpu0: AMD Unknown K7 (Athlon) (686-class), 2393.27 MHz, id 0x20f12

ISTR that i386 kernels don't bother to recognize newer and/or amd64
processors with great accuracy.

>  SAS Adapter (vendor 0x1000 product 0x0050):
>   I realize that the LSI Adapter 1064 is not supported by the mpt
>   driver and the vendor/product id was missing until yesterday.
>  ATI (vendor id 0x1002) and AMD (vendor id 0x1022) devices:
>   I do not understand why all those devices are only shown with their
>   numerical id. As I just looked them up, all of them were already
>   listed in pcidevs, so why does the autoconfiguration say
>     ppb0 at pci0 dev 1 function 0: vendor 0x1022 product 0x7450 (rev. 0x1=
>   instead of
>     ppb0 at pci0 dev 1 function 0: AMD AMD8131 PCI-X Tunnel (rev. 0x13)
>   ?

INSTALL kernels don't include the strings to save necessary space.

>  USB problems:
>   A USB keyboard directly attached to the x4200 worked correctly until I
>   pulled the plug and got
>   : at uhub2 port1 (addr 5) disconnected
>   panic: config_detach: forced detach of  failed (45)
>   Stopped in pid 4.1 (usb1) at    0xc02d3541:  leave
>   ddb>
>   An external USB floppy drive from NEC caused a panic when it was
>   connected at boot time and disconnected later on:
>   uvm_fault (0xc09d8ee9, 0, 1) -> 0xe
>   kernel: supervisor trap page fault, code =3D 0
>   Stopped in pid 4.1 (usb1) at 0xc029001f: cmpl $0,0x1c(%ebx)
>   ddb>
>   I was not able to get a trace because I ran out of time to provoke
>   this error again with a serial console. Maybe I can do this sometime
>   next week.
>   The x4200 machines from SUN have a separate service processor board
>   and the machine can be controlled by means of a Java applet from a
>   remote system. This applet redirects the remote mouse and keyboard to
>   the x4200 where the events appear to originate from a USB mouse and
>   keyboard (see "Virtual Keyboard and Mouse" in the kernel output above).
>   Even a remote ISO image can be redirected to the x4200 and appears as
>   a local CDROM ("Virtual Cdrom Device" above).
>   Unfortunately, the virtual keyboard did not work completely. While I
>   could type characters, almost every key generated
>    uhidev0: bad input length 8 !=3D 0
>    uhidev0: bad input length 8 !=3D 0
>   This distorted the sysinst screen slightly...

I'd guess that this thing has some quirks that are causing this.
Besides, Java and virtual USB keyboards, whatever happened to
serial consoles on high-end servers?

> ciao
>      Klaus

	Jonathan Kollasch

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.4.2 (NetBSD)