Subject: Re: Latest dovecot package completely broken
To: Geert Hendrickx <>
From: Scott Ellis <>
List: current-users
Date: 06/14/2006 09:51:59
Geert Hendrickx wrote:
> On Wed, Jun 14, 2006 at 08:41:00AM -0300, Jared D. McNeill wrote:
>> I've been having issues with dovecot lately, so I decided to upgrade to 
>> the latest version available in pkgsrc (1.0 beta9). After building and 
>> installing, the application failed to start. I forget the exact error 
>> strings, but something like 'socket() failed' followed by 'listen(993) 
>> failed'.
>> Dug into the code, and sure enough, it was doing absolutely brain-dead 
>> things like this:
>>    memset(&so, 0, sizeof(so));
>>    fd = socket(so.sin.sin_family, SOCK_STREAM, 0);
>> Hard-coding sin_family to be AF_INET after memset solved my immediate 
>> problem, but clearly this dovecot release and package could never have 
>> worked for anybody. Or am I going crazy here?
> It worked fine for me on my testing machine (with ssl enabled), so I
> committed the update to pkgsrc.  But then when I deployed it on my
> production setup I got the same error as you, so I reverted that machine
> to 1.0beta8nb1. :-(  I haven't looked into it any further.  It did work
> though when I disabled imaps and only started the non-SSL parts, you
> could use that as a work-around.  
> But please post your findings on the relevant dovecot mailing lists.  

This has been discussed on the Dovecot lists already, and is a bug in 
1.0b9.  The workaround is to add "ssl_listen = *:993" to your dovecot.conf.