Subject: gcc 3.3.6 import breaks build on -current
To: None <>
From: Henry R. Bent <>
List: current-users
Date: 06/05/2006 20:04:18
Hi all,

The 3.3.6 import seems to have broken the build (for at least i386) on 

auric# uname -a
NetBSD auric 3.99.18 NetBSD 3.99.18 (E4500) #0: Fri May  5 11:20:23 EDT 
2006  root@hbent3:/usr/obj/src-current/sys/arch/i386/compile/E4500 i386 
auric# ./ -m i386 -x -X /usr/src/src-current/xsrc release

--- lfs.o ---
#   compile  lfs_cleanerd/lfs.o
-O2  -Wall -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith 
-Wno-sign-compare -Wno-traditional  -Werror 
-I/usr/src/src-current/sbin/fsck_lfs  -nostdinc -isystem 
/usr/src/src-current/obj/destdir.i386/usr/include  -c 
/usr/src/src-current/sbin/fsck_lfs/lfs.c: In function `lfs_vop_strategy':
/usr/src/src-current/sbin/fsck_lfs/lfs.c:131: warning: implicit 
declaration of function `perr'

gcc version 3.3.6 (NetBSD nb1 20060605)

-Henry Bent
Oberlin College CIT