Subject: Re: __used__ prevents vax GENERIC from building
To: None <>
From: Christos Zoulas <>
List: current-users
Date: 05/24/2006 23:19:16
In article <>,
Kirk Russell  <> wrote:
>I cannot build current (HEAD/200605220000Z) for the vax port.
>The host is i386 NetBSD 3.0.
>Would using __used (from sys/cdefs.h), instead of __used__ be a fix?
>#   compile  GENERIC/param.o
>/bstg/current/vax/tools/bin/vax--netbsdelf-gcc -mno-asm-pic
>-ffreestanding -O2 -Werror -Wall -Wno-main -Wno-format-zero-length
>-Wpointer-arith -Wmissing-prototypes -Wstrict-prototypes -Wswitc
>h -Wshadow -Wcast-qual -Wwrite-strings -Wno-sign-compare
>-Wno-uninitialized -D_VAX_INLINE_ -I.
>-I/bstg/current/usr/src/sys/arch -I/bstg/current/u
>sr/src/sys -nostdinc -DLKM -DMAXUSERS=8 -D_KERNEL -D_KERNEL_OPT
>-I/bstg/current/usr/src/sys/dist/ipf -c param.c
>cc1: warnings being treated as errors
>In file included from param.c:72:
>config_file.h:20: warning: `__used__' attribute directive ignored

Fixed, cvs update and rebuild config.