Subject: Re: crosscompiling fails with "missing separator."
To: None <>
From: Havard Eidnes <>
List: current-users
Date: 05/11/2006 23:57:23
> On Thu, 2006-05-11 at 11:02 +0200, Havard Eidnes wrote:
> > Secondly, I'd say it's at best unconventional to use relative
> > paths as arguments to -O and -T.  Please try to use absolute
> > paths instead and see if that improves the situation. =

> thanks for your answer, I have tried your advice but it didn't improv=
> the situation.

Well, this looks like a different error?

> Anyway the official documentation advices me to use relative
> paths

Hm, OK.  Well, I never do that myself, though...

> I have updated the source tree today and tried it again using:
> # sh -m sparc64 -O /usr/obj -T /usr/tools -U -j 5 release
> now it stops here:
> ...
> =3D=3D=3D=3D=3D=3D=3D  2 extra files in DESTDIR  =3D=3D=3D=3D=3D=3D=3D=
> Files in DESTDIR but missing from flist.
> File is obsolete or flist is out of date ?
> ------------------------------------------
> ./usr/lib/
> ./usr/lib/
> =3D=3D=3D=3D=3D=3D=3D=3D=3D  end of 2 extra files  =3D=3D=3D=3D=3D=3D=

The major of libpcap was bumped a while back.  Did you have
UPDATE set in the environment, perhaps?  (The above command
doesn't say "-u" as an argument.)  Or was this snapshot of
-current taken at an inopportune time?


- H=E5vard