Subject: Re: & lex & dependall
To: Alan Barrett <>
From: Iain Hibbert <>
List: current-users
Date: 04/11/2006 11:46:16
On Sun, 9 Apr 2006, Alan Barrett wrote:

> On Sun, 09 Apr 2006, Iain Hibbert wrote:
> > > Perhaps your copy of arlex.c is older than your copy of arlex.l, in
> > > which case deleting both and doing another cvs update might help.
> >
> > Hm, I wonder if this is the cause of my troubles.. should "cvs update"
> > preserve the server timestamps? It doesnt seem to be doing so (cvs
> > checkout does) and since arlex.c arrives first it has the older
> > timestamp..
> No, cvs update doesn't preserve timestamps.
> Please try the appended patch, which should stop the reachover make
> from trying to run yacc or lex.

Yes, that does seem to work thanks.

I was already building a world as root, which worked but modified the
arlex.c file - then I built a world as unprivileged user and that worked
but the timestamps on the arlex.c file were such that it wasnt trying to
be built. I deleted arlex.c and arlex.l and did 'cvs update' to replace
them and have a build running now that I think has passed the previous
fail point.

but I wonder, this seems a bit of a hack to get around the fact that the
arlex.c file exists in CVS in the first place - is there a good reason for
that? I see there are several other similarly 'intermediate' source files
in that directory, I guess they are just part of the distribution..