Subject: Can't load LKMs on -current/amd64: .eh_frame overlaps .data
To: None <>
From: Dave Huang <>
List: current-users
Date: 02/25/2006 20:06:48
On -current/amd64 with Feb 19 kernel and userland, I'm having problems loading LKMs. E.g.,

ld: section .eh_frame [ffffffff80651768 -> ffffffff8065261f] overlaps section .data [ffffffff806525c0 -> ffffffff80652a27]
modload: can't link `/usr/lkm/udf.o' creating `/usr/lkm/udf' bound to 0xffffffff8064c000

I was thinking that perhaps the LKMs were messed up, but I get the
same message trying to load an LKM that worked fine before. As a
kludge, I changed modload to call ld with the --no-check-sections
flag, and that seems to have worked OK. (Alas, my NIC driver is an
LKM, so I was pretty much hosed without it).
Name: Dave Huang         |  Mammal, mammal / their names are called /
INet: |  they raise a paw / the bat, the cat /
FurryMUCK: Dahan         |  dolphin and dog / koala bear and hog -- TMBG
Dahan: Hani G Y+C 30 Y++ L+++ W- C++ T++ A+ E+ S++ V++ F- Q+++ P+ B+ PA+ PL++